java is required for viewing webcam.

If you have java installed in your browser and it is up to date and you are still experiencing problems with Internet Explorer such as a white band that flickers, please use:

[button link=”http://fergusonmuseum.org/osprey-cam/ospreycam-alternate/” color=”blue” size=”medium”]OspreyCam Alternate Page[/button]

Webcam is best viewed with Firefox, Safari or Chrome browsers.